MikroTik Deteksi IP Lokal / Public Indihome

Kecepatan koneksi dan harga Indihome menjadi daya tarik tersendiri bagi banyak user. Namun belakangan ada sedikit permasalahan bagi sebagian user, yaitu persoalan IP Private ketika terhubung dengan jaringan Indihome.

Hal ini di lakukan oleh Telkom karena keterbatasan alokasi IPv4 milik mereka yang sekarang (mungkin) sudah mulai running out atau habis karena semakin meningkatnya jumlah pelanggan produk internet fiber.

Efeknya adalah bagi user yang menggunakan fitur Opendns dll, yang digunakan untuk meremote perangkat dibelakang router.

MikroTik Deteksi IP Lokal / Public Indihome

Nah, berikut trik bagi user mikrotik yang dial Indihome melalui mikrotik, supaya tidak memperoleh IP Private dari Indihome.

Masuk ke menu PPP >> Profile

Kemudian buat Profile baru

Copy paste kan saja script dibawah ini pada tab script bagian on-up, jangan lupa bagian “pppoe-out1” di ubah menyesuaikan nama interface yang melakukan dial PPPoE, kebetulan di tempat saya bernama “pppoe-out1”.

Copy paste script dibawah ini, dan pilih salah satu script dibawah ini :

Script Pertama

:local PPPOEINTERFACE
:set PPPOEINTERFACE pppoe-out1

:log warning "Proses Cek IP..."
:while ([/ping 8.8.4.4 count=1] != 1) do={:delay 0.2}
:local IPWAN [/ip address get [find where interface=$PPPOEINTERFACE] address];
:set IPWAN [:pick $IPWAN 0 ([:len $IPWAN]-3) ];

:if ($IPWAN ~"^[0-9 ]*10") do={
:log warning "Terdeteksi IP Private !!!"
:log warning "IP address anda  $IPWAN"
:log warning "Reconnecting......"
/interface pppoe-client disable $PPPOEINTERFACE
:delay 3
/interface pppoe-client enable $PPPOEINTERFACE
} else={

:if ($IPWAN ~"^[0-9 ]*172") do={
:log warning "Terdeteksi IP Private !!!"
:log warning "IP address anda $IPWAN"
:log warning "Reconnecting......"
/interface pppoe-client disable $PPPOEINTERFACE
:delay 3
/interface pppoe-client enable $PPPOEINTERFACE
} else={
:if ($IPWAN ~"^[0-9 ]*192") do={
:log warning "Terdeteksi IP Private !!!"
:log warning "IP address anda $IPWAN"
:log warning "Reconnecting......"
/interface pppoe-client disable $PPPOEINTERFACE
:delay 3
/interface pppoe-client enable $PPPOEINTERFACE
} else={

:log warning "Selamat!!!, Terdeteksi IP Public !!!"
:log warning "IP address anda $IPWAN"
}
}
}

Script Kedua

# Variables
:local currentLocalSiteInterface "pppoe-out1-indihome"
:local privateRanges {192.168.0.0/16; 172.16.0.0/12; 10.0.0.0/8} 
:local loopCount 20

# Script
:local hadMatch
:local currentLoop 0

:if ([/interface pppoe-client get [/interface pppoe-client find name=$currentLocalSiteInterface] running]) do={
   do {
      :set hadMatch false
      :local currentLocalSite [/ip address get [/ip address find interface=$currentLocalSiteInterface] address]
      :local currentLocalSiteAddress ([:pick $currentLocalSite 0 [:find $currentLocalSite "/"]] & \
         (255.255.255.255 << (32 - [:pick $currentLocalSite ([:find $currentLocalSite "/"] + 1) [:len $currentLocalSite]]))) 
         
      :foreach privateRange in=$privateRanges do={ 
         :if (([:pick $privateRange 0 [:find $privateRange "/"]] & \
            (255.255.255.255 << (32 - [:pick $privateRange ([:find $privateRange "/"] + 1) [:len $privateRange]]))) = \
            ($currentLocalSiteAddress & (255.255.255.255 << (32 - [:pick $privateRange ([:find $privateRange "/"] + 1) [:len $privateRange]])))) do={ 
                /interface disable $currentLocalSiteInterface
                :delay 2
                /interface enable $currentLocalSiteInterface
                :set hadMatch true
            :log error "WAN IP address matched private IP address - $privateRange"
         } 
      }
      :set currentLoop ($currentLoop + 1)
  
      :if ($hadMatch) do={
        :delay 2
      }
   } while (($currentLoop < $loopCount) && ($hadMatch))  
}

Dua script diatas memiliki fungsi yang sama, cukup pilih salah satu saja ……

Selamat mencoba ….

sumber : sehitam-kopi.blogspot.com/2019/06/mikrotik-auto-redial-pppoe-jika.html + fazar.net/mikrotik-trik-mendeteksi-pppoe-telkom-ip-lokal-shared-ip-publik/

Share on facebook
Share on twitter
Share on linkedin
Share on telegram
Share on whatsapp
Share on email
@boysetyadin
  • kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
  • ada yang bisa diandalkan, tapi bukan kamu ...
  • waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. 

tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021.

Allah lebih tau mana yang terbaik ...
  • setelah sekian purnama
  • halo selamat pagi, kita ketemu lagi
  • 4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 

Selasa - Jumat, 26 - 29 Oktober 2021 

Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi
Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. 
 
Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. 

"Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i

#salamgrounded
#groundedtotalmarketing
#gtm
#coachdrfahmi
#menolakkalah
#menolaklemah
  • tarik sis ...
  • seribu alasan kamu berharga
  • masih, rasa yang sama ... pahit dan asam
  • ball boy

#bodiwebid #havingfun #ball #swim
  • ketika aku mengenalmu, dan kamu berlalu dalam bayang2

#bodiwebid #alunalunpurworejo
  • pagi ....
kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
3 months ago
View on Instagram |
1/12
ada yang bisa diandalkan, tapi bukan kamu ...
ada yang bisa diandalkan, tapi bukan kamu ...
3 months ago
View on Instagram |
2/12
waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. 

tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021.

Allah lebih tau mana yang terbaik ...
waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021. Allah lebih tau mana yang terbaik ...
1 year ago
View on Instagram |
3/12
setelah sekian purnama
setelah sekian purnama
2 years ago
View on Instagram |
4/12
halo selamat pagi, kita ketemu lagi
halo selamat pagi, kita ketemu lagi
2 years ago
View on Instagram |
5/12
4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 

Selasa - Jumat, 26 - 29 Oktober 2021 

Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi
Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. 
 
Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. 

"Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i

#salamgrounded
#groundedtotalmarketing
#gtm
#coachdrfahmi
#menolakkalah
#menolaklemah
4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 Selasa - Jumat, 26 - 29 Oktober 2021 Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. "Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i #salamgrounded #groundedtotalmarketing #gtm #coachdrfahmi #menolakkalah #menolaklemah
3 years ago
View on Instagram |
6/12
tarik sis ...
3 years ago
View on Instagram |
7/12
seribu alasan kamu berharga
seribu alasan kamu berharga
5 years ago
View on Instagram |
8/12
masih, rasa yang sama ... pahit dan asam
masih, rasa yang sama ... pahit dan asam
5 years ago
View on Instagram |
9/12
ball boy

#bodiwebid #havingfun #ball #swim
ball boy #bodiwebid #havingfun #ball #swim
5 years ago
View on Instagram |
10/12
ketika aku mengenalmu, dan kamu berlalu dalam bayang2

#bodiwebid #alunalunpurworejo
ketika aku mengenalmu, dan kamu berlalu dalam bayang2 #bodiwebid #alunalunpurworejo
5 years ago
View on Instagram |
11/12
pagi ....
5 years ago
View on Instagram |
12/12

Artikel Menarik