Otomatis Menambahkan Queue Simple Dengan Lease Script DHCP

Mungkin ada yang berpikir gimana caranya memberikan limit user Lease DHCP secara otomatis. Nah, saat ini Mikrotik sudah memberikan jawabannya dengan fitur Lease Script. Yaitu fitur script yang dapat disematkan pada jendela DHCP Server, berikut penjelasan singkatnya.

Terdapat beberapa variabel pada lever global yang dapat kita gunakan untuk menunjang script yang akan kita buat yaitu :

  • $leaseBound
  • $leaseServerName
  • $leaseActMAC
  • $leaseActIP

Untuk sedikit informasi, berikut penjelasan mengenai variabel diatas:

$leaseBound akan memiliki value “1” jika DHCP server sudah memberikan IP kepada client, dan tentunya akan value akan berubah menjadi “0” jika IP sudah dilepaskan. Ini akan sangat berguna untuk mendeteksi aktif tidaknya client.

$leaseServerName memiliki value berupa nama DHCP Server yang terkoneksi dengan client.

$leaseActMAC memiliki value berupa mac address dari client yang menerima ip dari DHCP server.

$leaseActIP memiliki value berupa IP address dari client yang menerima ip dari DHCP server.

Dengan variabel-variabel diatas tentu kita dapat membuat berbagai script sesuai dengan kebutuhan, sebagai contoh kali ini akan dicoba mengemplemantasikannya untuk membuat simple queue otomatis, yang mana nantinya setiap client yang mendapatkan ip dari DHCP server maka akan dibuatkan simple queuenya secara otomatis.

Sebagai studi kasus, misalnya user menginginkan semua client dibuatkan simple queue otomatis, namun ada beberapa client dengan mac address tertentu memiliki jumlah limit yang berbeda tetapi masih pada parent yang sama.

Dari studi kasus diatas maka harus kita tentukan dulu besarnya limit client sesuai dengan permintaan, lalu tentukan mac address client mana saja yang “dikhususkan” limitnya, kita ambil contoh saja :

  • Limit client umum upload 2Mbps dan Download 3Mbps
  • Limit client khusus upload 3Mbps dan Download 5Mbps
  • Contoh Mac Address client khusus “C4:2A:FE:60:74:64” dan “C4:2A:FE:55:94:03”;
  • Parent menggunakan parrent yang sama.

Sebagai catatan script yang akan dibuat disini hanya sebagai contoh, jadi jika dikira masih kurang dapat dilengkapi sendiri.

Pertama yang akan kita buat adalah parent dari simple queue yang akan kita buat, sebagai contoh kita beri nama  “TOTAL” dengan limit upload 20Mbps dan Download 20Mbps, kita tambahkan secara manual di simple queue.

Kemudian kita tambahkan script berikut pada Lease Script yang ada pada DHCP server yang tentunya sudah kita buat.

:local client1 "C4:2A:FE:60:74:64";
:local client2 "C4:2A:FE:55:94:03";
:local queName "Client-$leaseActMAC";
:local queParent "TOTAL";

:if (($leaseActMAC = $client1) or ($leaseActMAC = $client2)) do={
/queue simple add name=$queName target=($leaseActIP."/32") max-limit=3M/5M parent=$queParent;
} else={
:if ($leaseBound = "1") do={
/queue simple add name=$queName target=($leaseActIP."/32") max-limit=2M/3M parent=$queParent;
} else={ /que simple remove $queName;}
}

 

Script diatas sudah dapat mengakomodasi studi kasus yang kita hadapi, tentunya dengan opsi yang sangat sederhana.

Gambar di atas menunjukan script yang dibuat dapat berjalan dengan baik.

Semoga bermanfaat, dan selamat mencoba

 

sumber : sehitam-kopi.blogspot.com/2020/11/menambahkan-queue-otomatis-menggunakan.html

Share on facebook
Share on twitter
Share on linkedin
Share on telegram
Share on whatsapp
Share on email
@boysetyadin
  • kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
  • ada yang bisa diandalkan, tapi bukan kamu ...
  • waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. 

tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021.

Allah lebih tau mana yang terbaik ...
  • setelah sekian purnama
  • halo selamat pagi, kita ketemu lagi
  • 4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 

Selasa - Jumat, 26 - 29 Oktober 2021 

Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi
Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. 
 
Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. 

"Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i

#salamgrounded
#groundedtotalmarketing
#gtm
#coachdrfahmi
#menolakkalah
#menolaklemah
  • tarik sis ...
  • seribu alasan kamu berharga
  • masih, rasa yang sama ... pahit dan asam
  • ball boy

#bodiwebid #havingfun #ball #swim
  • ketika aku mengenalmu, dan kamu berlalu dalam bayang2

#bodiwebid #alunalunpurworejo
  • pagi ....
kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
1 month ago
View on Instagram |
1/12
ada yang bisa diandalkan, tapi bukan kamu ...
ada yang bisa diandalkan, tapi bukan kamu ...
1 month ago
View on Instagram |
2/12
waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. 

tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021.

Allah lebih tau mana yang terbaik ...
waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021. Allah lebih tau mana yang terbaik ...
1 year ago
View on Instagram |
3/12
setelah sekian purnama
setelah sekian purnama
2 years ago
View on Instagram |
4/12
halo selamat pagi, kita ketemu lagi
halo selamat pagi, kita ketemu lagi
2 years ago
View on Instagram |
5/12
4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 

Selasa - Jumat, 26 - 29 Oktober 2021 

Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi
Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. 
 
Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. 

"Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i

#salamgrounded
#groundedtotalmarketing
#gtm
#coachdrfahmi
#menolakkalah
#menolaklemah
4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 Selasa - Jumat, 26 - 29 Oktober 2021 Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. "Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i #salamgrounded #groundedtotalmarketing #gtm #coachdrfahmi #menolakkalah #menolaklemah
2 years ago
View on Instagram |
6/12
tarik sis ...
3 years ago
View on Instagram |
7/12
seribu alasan kamu berharga
seribu alasan kamu berharga
4 years ago
View on Instagram |
8/12
masih, rasa yang sama ... pahit dan asam
masih, rasa yang sama ... pahit dan asam
4 years ago
View on Instagram |
9/12
ball boy

#bodiwebid #havingfun #ball #swim
ball boy #bodiwebid #havingfun #ball #swim
5 years ago
View on Instagram |
10/12
ketika aku mengenalmu, dan kamu berlalu dalam bayang2

#bodiwebid #alunalunpurworejo
ketika aku mengenalmu, dan kamu berlalu dalam bayang2 #bodiwebid #alunalunpurworejo
5 years ago
View on Instagram |
11/12
pagi ....
5 years ago
View on Instagram |
12/12

Artikel Menarik