Install Letsencrypt di Debian 9 dengan Snapd

Debian 9 ternyata sudah tidak disupport secara langsung ketika install Letsencrypt menggunakan Certbot atau script letsencrypt-auto. Error ditandai dengan munculnya pesan seperti berikut : root@bodi:~/src/letsencrypt# ./certbot-auto renew –apache Skipping bootstrap because certbot-auto is deprecated on this system. Your system is not supported by certbot-auto anymore. Certbot cannot be installed. Please visit https://certbot.eff.org/ to check for […]

Mengatasi LetsEncrypt Invalid Response Acme-Challenge

Terkadang pada saat proses renewal Certs Letsencrypt sebuah domain muncul pesan error seperti dibawah : kemudian menyusul pesan error berikut : Mungkin secara logika dapat saja dibuatkan folder pada root domain sesuai dengan yang tertera diatas, tapi setelah aku coba ternyata tidak berhasil. Untuk menyelesaikan itu cukup dengan menjalankan perintah (khusus yang menggunakan Nginx) berikut […]

Menangani Masalah Certbot Lets Encrypt dan Python Virtual Environment

Pada proses pembaharuan certificate Letsencrypt terkadang mengalami masalah dan muncul error message seperti dibawah : Untuk mengatasi masalah tersebut ternyata hanya perlu menambah Swap saja, karena dari pesan error tersebut sudah cukup jelas harus menambah memory. Ini terjadi karena VPS hanya memiliki RAM 512Mb saja, nah untuk menambah Swap cukup lakukan langkah-langkah seperti dibawah ini […]

Gagal Renew LetsEncrypt, Dan Cara Memperbaikinya

Seandainya teman-teman ada yang mengalami masalah yang sama, mungkin cara ini adalah solusinya. root@bodi.web.id:~/src/letsencrypt# ./letsencrypt-auto renew Upgrading certbot-auto 0.31.0 to 0.32.0… Replacing certbot-auto… Error: couldn’t get currently installed version for /opt/eff.org/certbot/venv/bin/letsencrypt: Traceback (most recent call last): File “/opt/eff.org/certbot/venv/bin/letsencrypt”, line 7, in from certbot.main import main File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/main.py”, line 10, in import josepy as jose File […]