Duck DNS Update Script For Mikrotik

Duck DNS Update Script For Mikrotik

# Duck DNS Update Script for MikroTik RouterOS 5.26 behind NAT

#--------------- Change Values in this section to match your setup ------------------

:local ducktoken "your-token"
:local duckdomain "your-domain"
:local ddnshost "$duckdomain.duckdns.org"

#------------------------------------------------------------------------------------
# No more changes need

:local ipddns [:resolve $ddnshost]

/tool fetch mode=http address="icanhazip.com" src-path="/" dst-path="/icanhazip.txt"
:delay 3
:local result [/file get icanhazip.txt contents]

:local resultLen [:len $result]
:local endLoc [:find $result "\n" -1]
:local ipfresh [:pick $result 0 $endLoc]
:log info "Duck DNS: IP detected from icanhazip.com is $ipfresh"

:if ($ipddns != $ipfresh) do={
    :log info "Duck DNS: Old IP is $ipddns"
    :log info "Duck DNS: New IP is $ipfresh"
    /tool fetch url="http://www.duckdns.org/update\?domains=$duckdomain&token=$ducktoken&ip=$ipfresh" dst-path=duckdns.txt
    :global ipddns $ipfresh
    :log info "Duck DNS: IP updated to $ipfresh!"
    } else={
     :log info "Duck DNS: Current IP is $ipddns"
     :log info "Duck DNS: Detected IP is same with current IP, dont need changes"
    }
}

 

source : http://wingloon.com/2014/06/28/duck-dns-update-script-for-mikrotik-routeros-5-26-behind-nat/

Share on facebook
Share on twitter
Share on linkedin
Share on telegram
Share on whatsapp
Share on email
kamu tak pernah salah, begitupula aku, tapi aku tau siapa yang paling benar 😆
3 months ago
View on Instagram |
1/12
ada yang bisa diandalkan, tapi bukan kamu ...
3 months ago
View on Instagram |
2/12
waktu dibuatkan minuman pemusnah sakit tenggorokan dan batuk ini, pikiranku melayang ke awal Maret 2021, dimana aku dan keluarga di Jateng sempat terkena Long Covid kalau orang bilang, dan Ibu mengirimkan beberapa botol minuman racikan ini utk obat. tapi sungguh tdk disangka, setelah kami sembuh Ibu justru berpulang karena Covid di bulan Juli 2021. Allah lebih tau mana yang terbaik ...
1 year ago
View on Instagram |
3/12
setelah sekian purnama
2 years ago
View on Instagram |
4/12
halo selamat pagi, kita ketemu lagi
2 years ago
View on Instagram |
5/12
4 days New Workshop Grounded Total Marketing (GTM) Lead by Coach Dr. Fahmi Angkatan 2 Selasa - Jumat, 26 - 29 Oktober 2021 Alhamdulilah diberi kesempatan untuk mengikuti workshop GTM yang dibimbing langsung oleh ahlinya @coach.fahmi Insyaallah saya siap hadir dan siap menerima semua ilmu yang diberikan selama mengikuti kegiatan GTM. Mudah-mudahan dengan semua ilmu yang saya dapatkan nanti, dapat membantu saya untuk mengoptimalkan kinerja saya dalam perusahaan. Menuntut ilmu adalah sesuatu yang harus dilakukan apabila seseorang ingin terus berkembang dan bertumbuh, dan Insyaallah saya siap melakukannya. "Bila kau tak tahan lelahnya belajar, maka kau harus menahan perihnya kebodohan" Imam Asy Syafi'i #salamgrounded #groundedtotalmarketing #gtm #coachdrfahmi #menolakkalah #menolaklemah
3 years ago
View on Instagram |
6/12
seribu alasan kamu berharga
5 years ago
View on Instagram |
8/12
masih, rasa yang sama ... pahit dan asam
5 years ago
View on Instagram |
9/12
ball boy #bodiwebid #havingfun #ball #swim
5 years ago
View on Instagram |
10/12
ketika aku mengenalmu, dan kamu berlalu dalam bayang2 #bodiwebid #alunalunpurworejo
5 years ago
View on Instagram |
11/12

Artikel Menarik

Exit mobile version